viernes, 31 de octubre de 2008

Ya no sera Pfsense 1.3.x, Ahora sera 2.0

Acabo de lleer la noticia en el blog de pfsense, se ha decidido renombrar la version 1.3.x a 2.0, esto dado a los cambios y avances en esta version, otro motivo es que la configuracion de una version 1.x.x no sera compatible con la 2.0 (a modo personal he realizado pruebas con la 1.3.x y el fail over y el load balancing cambia mucho) por ahora, el grupo de tarea esta realizando todos los ajustes, para tener funcional todo lo que se refiere a la paqueteria en la 2.0, para los que desen migrar a esta nueva version, deberan configurar desde cero(es mi recomendacion personal).

saludos...

domingo, 26 de octubre de 2008

DVD Freebsd 7.0

Bueno, si buscáis en Internet, encontraran varios links del como crear un DVD de freebsd 7.0 a partir de las imágenes CD que pueden descargarse desde www.freebsd.org, como muchos de otros usuarios de freebsd, se ha vuelto un poco laboriozo instalar freebsd con los CDs, (sacar un cd, para meter el cd2, para luego meter el cd1 etc, etc, etc,...) asi que me propuse crear mi DVD de FreeBSD 7.0, para esto estan todos estos links:
http://fids.wordpress.com/2008/09/11/crear-tu-propio-freebsd-dvd/
http://it.toolbox.com/blogs/bsd-guru/creating-your-own-freebsd-70-dvd-22791
http://angelvg.blogspot.com/2007/01/freebsd-62-release.html

si verifican los procedimientos son parecidos, mas tienen un pequeño fallo(a mi parecer), cuando cree la imagen, y la probe con una maquina virtual, me dio mensajes de error, ya que seguia pidiendo el disco1, "desmonte el disco 0 y coloce el disco 1" en español... bueno el ultimo link, tiene la solucion, el archivo cdrom.inf debe quedar asi:
CD_VERSION = 7.0-RELEASE
CD_VOLUME = 1




domingo, 19 de octubre de 2008

system_tools_backends

Muchos usuarios y administradores que se están iniciando en el mundo de FreeBSD y vienen de linux, cuando instalan Gnome se sorprende al ver que cuando intentan configurar su tarjeta de red o crear un usuario (es decir administración básica el FreeBSD) este les da un mensaje indicando "No se pudo cargar la configuración", cualquiera (mi incluyo se rompería la cabeza buscando en documentación, o en la web,[si buscaste en Google posiblemente llegaste aquí]) incluso sin mal no recuerdo creo que esto se a preguntado a la lista, ahora no recuerdo si se le dio solución desde allí, por lo pronto, he instalado desde cero mi FreeBSD de casa (es que el amigo Green me ha hecho una pregunta sobre este tema y la verdad yo tenia funcionando desde 6.0 bien y no recordaba que se necesitaba) pues bien, luego de respaldar mis archivos, he instalar todo desde cero, me localizo como muchos de vosotros con el mismo dilema, "No se pudo cargar la configuración" pues bien, antes se tenia que instalar algunas cosas de forma manual, dbus, hal, polkit, con FreeBSD 7.0 ya esto viene durante la instalación de Gnome, asi que solo con añadir estas lineas a /etc/rc.conf
polkitd_enable="yes"
hald_enable="YES"
dbus_enable="YES"

Con esto tenemos que el auto montaje de unidades debe funcionar, ademas de hibernacion y otras cosas, pero cuando arrancamos el demonio dbus nos saldrá un mensaje de que el usuario haldaemon no existe, bueno la solución es simple, creamos un usuario con este nombre, sin password, useradd haldaemon, luego le damos un /usr/local/etc/rc.d/dbus restart y listo, ahora deben modificar los permisos para que los usuarios accedan a los pendrive y puedan montarlos y escribir en ellos,
editamos los archivos que están en /usr/local/etc/policykit/privilege.d/ por defecto estarán así:

[Policy]
Allow=
Deny=

debemos dejarlos así:


[Policy]
Allow=uid:__all__
Deny=

De esta forma ya esta funcionado para cualquier usuario.
ahora el demonio system_tools_backends necesita de dbus para funcionar, luego de tener corriendo dbus, añadimos a nuestro rc.conf la linea system_tools_backends_enable="YES", y listo.

Recomendaciones: es facil trabajar en ambiente gráfico, pero se aprende mucho desde la consola, y si por algún motivo les toca administrar un servidor que no tenga Xorg instalado se verán en aprietos, asi que a usar el modo texto (creo que la principal razón por la que Gnome arroja el error de que el root no se debe ejecutar es porque es sencillo estropear todo el sistema con un simple click)

Ahora solo me queda actualizar los ports y cambiar mi kernel a gusto, ademas de configurar mi nvidia fx5200.

saludos...

FreeBSD

Loading...

Windows Vista AERO VS Linux BERYL

Loading...